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Portable Document Format (PDF)

» Created by Adobe in 1990s to
preserve visual format and allow
easy sharing of documents

« Offers many accessibility features
but must be deliberately
incorporated

» Has a reputation of being difficult
and frustrating to remediate




PDF/Universal Accessibility (PDF/UA)
Standards

e Technical standards for created accessible PDFs
« Based on WCAG 2.0 principles

* Follows the Matterhorn Protocol
* 31 checkpoints for possible ways to fail PDF/UA

« WCAG and PDF/UA are similar with overlap and differences



How many measurable WCAG Guidelines are

there to create accessible web content?

. 32
. 44
. 78
. 92
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Does WCAG Apply to PDF?

The short answer is, yes.



The Basics of Accessible PDFs

N o O~ O =

Optimize the source document for accessibility

Save the file as a tagged PDF

Provide metadata for the PDF (such as document language)
Create and edit tags (similar to HTML tags)

Ensure the reading order is logical

Ensure the tab order is sequentially correct

Check PDF with automated and manual testing for
accessibllity
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What are Tags?

* Invisible labels that provide
significant information

 Critical for assistive
technology

« Semantic structure of what
the document is about and
how it's organized

* Very important step to ensure
accessibllity
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Accessibility tags

C‘j’ <Hlz
C‘j’ <HIx
1‘| <P
ol <Tablex
1‘| <P
C‘j’ <HIx
1‘| <P
ol <Tablex
1‘| <P
1‘| <P
C‘j’ <O
1‘| <P
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Remediation Flow of PDFs

General workflows for different scenarios



Easiest & Fastest:
Start with the source document ...

s Convert to . Fine Tune
Optimize Source Doc Tagged PDF Add Metadata Add/Edit Tags Reading & Tab

Check
Accessibility

Order
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If you start with an untagged PDF file ...
(and don’t have the source)

Add/Edit Tags s TUAe Check

Add Metadata Reading & Tab

(Auto/Manual) Order Accessibility




If you start with a paper or a scanned
document ...

: Fine Tune
Scan document Apply OCR Add Metadata Add/Edit Tags

. Check
(Auto/Manual) Read(;r:ge% 1l Accessibility
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Presenter Notes
Presentation Notes




Easiest & Fastest Route of PDF Remediation:
Start with an Optimized Source File

* Real, semantic elements
* Headings

* Text

 Alternative (ALT) text
 Color contrast

* Links

 Tables



Headings

Home Insert Draw Design Layout References Mailings Review

o, A = A § o £

° Re a I b S e m a n ti C h e a d i n g S Pasta ¢ Font Paragragh Styles Dictate Sansitivity Add-ing Editor

aaBbceDdE | AaBbCc AaBbCeDi | Gﬁ

° Start at Ievel 1 Aaitf::dE Mo Spacing Heading 1 Heading 2 Styles
* Not skip any levels
* Logical outline of hierarchy
Outlining Home Insert Draw Design Layout References

* Accurate, informative and € €t s> p | T Sowimer e 3

v Show Text Formatting
Show

CO n CI Se S Show First Line Only Document 5
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Text Ghiis is hind of hard to read, isn tit?

* Fonts are easily readable This font is clear and easy to read.
* Line spacing is at least 1.5 within

paragraphs i Ny
) Paragraph SpaCing iS at Ieast 1.5 standard chievement for all

times larger than line spacing
 Text is not fully justified
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Alternative (ALT) Text

* All meaningful images, graphs
& charts, and other non-text o

How would you describe this object and its

content have alt text. o e

- The setting
- The actions or interactions
- Other relevant information

» Accurately conveys its
purpose

(1-2 detailed sentences recommended)

Dog with collar sitting outdoors on wood park
bench

* [t IS concise

Generate alt text for me

 All meaningful non-text
content has a long description
when needed (for example: a
complex graph)



Color Contrast

» Text/Fonts
* Regular text (18pt normal or 14pt bold)

* Min. 4.5:1 ratio with the background
» Large text (>18pt)
« Min. 3:1 ratio with the background

» User Interface Components and Graphical Objects:

« Min 3:1 ratio against adjacent colors
« Buttons
 |cons that convey information
« Graph or chart components (ex. Graph lines/shapes)

 Form field text boxes

 Colour Contrast Analyser

Foreground colour

Background colour

Colour Contrast Analyser (CCA)

[HEX | #FFFFFF

¥ Sample preview

example text showing contrast [m;

WCAG 2.1 results

Contrast ratio

5.8:1

> 1.4.3 Contrast (Minimum}) (AA)

(¥) Pass (regular text)

(+) Pass (large text)

> 1.4.6 Contrast (Enhanced) (AAA)

€ Fail (regular text)

() Pass (large text)

> 1.4.11 Non-text Contrast (AA)

(¥) Pass (Ul components and graphical objects)
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https://developer.paciellogroup.com/color-contrast-checker/

Links

 Correctly designated

* Visually Join our Accessibility
distinguishable Community of Practice
(A11y CoP) today!

* Meaningful and not
generic


https://it.nc.gov/support/training-user-resources/user-groups-communities-practice/digital-accessibility-community-practice
https://it.nc.gov/support/training-user-resources/user-groups-communities-practice/digital-accessibility-community-practice
https://it.nc.gov/support/training-user-resources/user-groups-communities-practice/digital-accessibility-community-practice

Tables

* Real tables
* Properly formatted
* Have table headings

« Simple tables (one header
row and/or one header
column)

« Complex tables can be
problematic to tag properly
after PDF export

 No blank cells

m A11y CoP Topic

01-24-2024
02-27-2024
03-26-2024
04-30-2024
05-28-2024
06-25-2024
07-30-2024
08-27-2024
09-24-2024

Accessible PPTs

Document A11y

A11y Testing

Plain Language

DOJ Deep Dive Part 1

DOJ Deep Dive Part 2
Everyday Asst. Technologies
Asst. Technologies Demo

Alt Text



Converting Optimized Source File
to Tagged PDF


Presenter Notes
Presentation Notes
�


Saving as Tagged PDF from Word in Windows

1. Select File > Save as Adobe PDF

2. In the pop-up dialog, select i e
O pti o n S ¥ Enable .ﬂu:cessrlI:nil.rt\pr and Reflow with tagged Adobe PDF
- [ E‘Eii::::urd Headings to Bookmarks
3. Ensure Enable Accessibility and i e
Reflow with tagged Adobe PDF is ] onvert Comments
checked
4. Leave option Convert Word e e
Headings to Bookmarks selected D Curent oge

I Page(s)

5. Select OK
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Saving as Tagged PDF from Word in Mac

1. Select File > Save as

2. In the File Format drop-
M~ &~ 9 Desktop A Q

down menu, select PDF
3. Select the Best for

electronic distribution

and acceSSibiIity radio Online Locations File Format: PDF

button P 4 ° Zu?%{i;iil‘?,‘;t:ﬁ”éif?'n'i‘ESr“Jifo"d e \
4. SeleCt Export MNew Folder Cancel




What are PDF Bookmarks?

« Bookmarks are

@ 8 HE Q

generated automatically

» Based on heading
structure

M D e Ol

&

* A convenient way to
jump to sections

Bockmarks

B kb R

[1 Title far Every Page

u Meaningful Page Title

e H Language

D Primary Language of Page
[] Language of Parts within the Page

[:I Language Codes

~ [] Landmarks

u Creating Landmarks (HTML 5, ARIA)
u Best Practices for Landmarks

[l Backward Compatibility

Image credit: Deque

[ summary
~ [] [Eheckist
L
~ [] Page Tite

Title for Evary Page

= The g coinler BMUET ba presnt and BMUST
caan tat

a The peage <107 e MUET b cpidated when The weh

PN ——
Ieaningful Page Title

® Thes peage <1157 = MUST b miaarate and
fisr et b

& 1f g papge is the result of 3 user action or scripbed
chungeal cuntal, e ealof e onn e SHOLILD

desrribe the resut or chanpe of condest bo bhe user,
# The <uirler SHOULD be concse
= The page ctislex SHOULD be unique. If posible,

= The page «tislox SHOULD mabch [or ke wery dmifar
o} the top Beading in the main content.

Primary Languags of Page

« The grimary kinguage of thi page MUST bo
identiticd socuratcly on the Ehement.

= The primary bnguage of the page MUST be
identitied with a valid value on the <nerls element.

Lanpusags of Parts within the Page

= inling Linguags chasges MUST b idest Hied with &
walid Larg antribane.

Lanpeags Codex

» The lasguegge e MUST ks il

Creating Larsmrarks |[HTRIL & ARIA)
= Landmar ks SHOULD e e [

Fapeicla

= mm
f0aw v -
o @ 3
&S LI L AT PR TR S e

al wach of thi fallradng lindmarks: =
P p—— fo

o Thes tiztal maarshan of lindmerks SHOLRT ba
mirimizad o the sxent sppropriste for the conkent,

Enckward

= |arwfimaiks SHOLID Ba snade Backward cospatibb,

8T, ERiE,

Eeal Headngs
& Test thet acks as 2 heading wisally or sinaciurally
SHOULD be designated & a true beading In the
markup.
= Tesk that does not act as a heading wisually o
structuralty SHOUUD BOT be markad 22 5 heading.
Maaninglul Tust
« Headings MUST be accurate and Informative,
= Hooking texr SHOLLD be concise and relatively brict,
Outling/Hiararchy of Contant
+ Headings SHOULD convey a clear and acourate
struchsral gutling of the seolions of CORTent of 4 wed
PR
= Hoadings SHOULD NOT skip hiwrarchical vl
Huading Livel 1 Bact Practices
=+ Thes hegiening of the maln cerbest SHOUID sta
with cnls.

» Mot waeh pages SHOLWD have onby o -=1-.

Cmeignate Links Carrsctly
= Lirdkes BALST b ssdimand ically disigratad b sudh.
& Links and bationy SHOULD be desgrated
sermmnlivaly sornding Lo i funifiors.
ik Tewt
& A bnk MUST heve programmaticelly-discemible pest,
22 determined by the acoezcible namea calculakion
slgoetthm,
» The purpose of each link SHOULD be able to be
determined from the link text slone
& The Ink best SHOULD 8OT repeat the role ik}

Vidiens - YouTuze - Google Chrome |, o
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Untagged PDF Conversions

Beware! Takes time and effort



Ways to Produce Inaccessible, Untagged
Results Examples

« Scanning a document produces a single image
» Using Print > Save as PDF from a document or webpage

* Options within Acrobat such as create PDF from scanner,
screenshot, webpage, or clipboard.



Scan PDFs with Optical Character
Recognition (OCR) _

Acrobat Pro DC has a built-in N
OCR text recognition tool o

* Open file, go to Tools > Create &
Edit section > Enhance Scans >

Recognize Text > In This File
* Select Recognize Text
» Adjust reading and tab order as
needed




Reading Order, Tab Order and
Metadata

Acrobat Pro is required for PDF remediation



The Acrobat Pro Interface

View > Show/Hide >

Navigation Panes
(Side Panes on Mac)

* Navigation Pane
 Document Pane

 Tasks Pane

B

® 0 ® & v Stateof North Carolina.. % | + Create @0
Alltools  Edit  Convert  E-Sign h Find text or tools Q 5;5 = m a Al Assistant
All tools x x  Accessibility tags -

®A
2
C?A

@
@

—

[

CP)

3
&

Send for comments

Scan & OCR

Protect a PDF

Redacta PDF

Compress a PDF

Prepare a form

Add comments

Convert to PDF

Add a stamp

4

purpose]

This standand offers guidance for designing and delvering websites and dighal services to priortize a
digita-irst public expenance! In the State of Nortn Caroina. It cutines statltory requiraments, ciarfles
mandates, and expands on best practices for the state’s dgital assets.

Witn over 10.2 million constituents served annualy, the majorty of Interactions cocur online and
Increasingly on moblle devices. Recognizing the shift io digital channels as the pimary means of
engagement, state agencies are wed to develop and design telr websites and dighal services to meet
the puplic's expectatons for high-gualty, user-friendly experiences Mat are seamless, accessile, and
SECUrE by design. This 3pproach aims o ennancs customer satistaction, trust, and overall experience.

Content Lead

North Caralina Department of information Technoiogy (NCDIT) — Dighal Solutions Team

Scope

Except 36 otherwise provided, this standard applies o 3l Norh Carolina state agencles’ webshes and
digital services that are:

»  Malniaingd by an 3ga an agency; and

f-tacing weosites

» O <Hi»
» O <HI»
» q‘l <>
» B <Table>
> q <>
> O <H2>
3 q‘| <>
» B <Table>
» q‘l <>
» q‘l <>
» O <TOC>

Buaxooeone

Navigation Pane

NCDIT
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Navigation Pane x

Most important panes relevant to
accessibility

« Content
* Order
* (Accessibility) Tags

Accessibility tags ---

» <:j‘ <Hl>
» <:j‘ <Ha»
» 1‘| <P
= <Tablex
» 1‘| <P

» <:j‘ <Ha»

bl




Document Pane

* Main area which the
document is displayed

« Select text in this
pane to tag or
highlight previously
tagged text

POEose]

This standard offers guidance for designing and delvering websies and digital sendces io priodiize a
digita-first public experence’ In the State of North Carolina. It outines statutory requirements, darifles
mandates, and expands on best praciices for the state’s dightal assets.

With over 10.2 milllon constituenis served annualy, the majorty of Interactions occur online and
Increasingly on mobile devices. Recognizing the shift to dighal channeis as the primary means of
engagemend, siate agencies are wged to develop and deskgn thelr websites and dighal senvices to meet
the public's expaciadions for high-gualty, user-endly experences Mat are seamless, accessbie, and
secure by deslgn. This approach alms to enhance cusiomer satisfaction, rust, and overall exparience.

Content Lead

Narth Carolina Department of Information Technoiogy [NCDIT) — Dighal Soltions Team

Scope

Excapi a5 othenwise provided, this siandard applies to all Morth Carslina state agencies” wabshes and
digital sendces that are:

= Malniained by an agency direcily or by a contractor or othar entity on behalf of an agency; and
= lntended for use by the public

State agencies are also encawraged to apoly the requiremants of this standard o Intema-facing wensites
and digial services io the greatest extent pracicable.

This standard does not apply to third-party websltes or digital services, such as sodal media sites, that

are designed to faciitate online sharing of text or other media among communiles of usens, and that are
used by an agency fof that purpase.

NCDIT
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Tasks Pane

* Includes the
Accessibility tools

« Reading Order Tool
 Full Check

o

EH B 9 &

@ Prepare for accessibility

E‘}, Apply PDF standards

< Prepare for accessibility
Convert to PDF

Add a stamp [_8 Automatically tag PDF

Use a certificate

Use print production Change reading options

Measure objects
J @ Check for accessibility

Compare files
G‘E, Open accessibility report

Add rich media
(33 Identify form fields

Use guided actions
B3 Add alternate text

N Use setup assistant

E¢ Fix reading order

NORTH CAROLINA
DEPARTMENT OF
INFORMATION
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Reading Order

 After tagging document, check
content order by using Tags and
Order navigation panes.

» Key Points:

« Changing Tag order in the Tag Pane
does not affect the visual stacking
order

» Checking the Order in the Order
Pane affects the fag order.

x  Accessibility tags ---

» <\‘/‘—'i‘ <Hl>
» <\‘/‘—'i‘ HI>
» 1‘| <P

» Ef <Tablex
» 1‘| <P

» <\‘/‘—'i‘ HI>




Working in the Order Pane

Moving items in the Order Pane,
moves tags in the Tag Pane

Changing order in the Order
Pane, changes the visual stacking
order

Numbering relates to the stacking
order — not screen reader reading
order

You may need to use the Tags
Pane to fix order of multiple tags
next to each other

TfETS oinEnCe o iesigr mmmlmllgmmugmmmw e yiiri )
[aHfirst public experience’ in the State of Mm&wmhmMEmmwmwmmm&ﬁE
dates, and expands on best practices for the state’s digital assets.

mmlozﬂlmmmm:mgﬂemmd interactions ocewr online and
increasingly on mobile devices. izing the shift to digital channels as the primary means of
engagement, state ma‘e to dewelop and design their websites and digital senvices to meet
the public’s expectabons for high-quality, user-fiendly expenences that are seamless, accessible, and
secure by design. This approach aims o enhance customer satisfaction, trust, and oversll experience.

tentCead

Canolina Department of Information Technology (NCOIT) — Digital Solutions Team
Scope

mmzwmmummmm“mhhwm all North Carofina state agencies’ websites and
digital services that ane:
= Maintained by an agency Ier.ﬁfya'by contrachor or other entity on behalf of an agency: and
= Intended for use by the pub

State agencies are also encouraged to apply the requirements of this standard to intemal-facing websites
and digital senvices to the greatest extent practicable.

This standard does not apply to third-party websites or digital services, such as social media sites, that
are designed to facilitate online sharing of text or other media among communities of users. and that are
used by an agency for that purpose.

x  Order ® -

w @ digjtal-accessibility-usability-standard pdf

» m Page1
3 D Page 2
> D Page 3

' D Page 4

=] [1] Path
%= [2] This standard offers guidance
= Eu

= [3] Path Morth Carolina Departme

>[4 Peges
> [4 Peges
> [4 Page?
> [4 Peges
>[4 Pagesd
> [4 Pegel0
>[4 Pagen
>[4 Pegen2
> [1 Pagets
> [4 Pegend

NCDIT]

for designing

nt of Inform
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Working in the Tags Pane

« For simple documents, easiest way to define screen reading
order is within Tags Pane

« For documents more focused on visual presentation, you
may need to use the Order Pane to fix the reading order

* Analyze your content
« Headings should be read before its associated content

 In long quotes, with speakers name at bottom, it's better
to read it first for screen readers to know who the quote is
from

* |f content refers to footnotes, sometimes it's appropriate
that they are read immediately following the associated
content rather than at the end.

« Arrange tags in a logical reading order (drag/drop)

x

Accessibilitytags @

3 @ < Table

1‘| <P
0 cHEm

3 1‘|~1F:~

@ < Table

1‘| <P

3 1‘| <P
0 < T
1‘| <P
"t 0 <Hi>

= | Purpase Path

W

W

W

W

W

W

3 1‘|~1F:~

3 1‘|~1F:~

NCDIT]
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Tab Order

Documents with links or form fields
must have tab order defined

* Open the Page Thumbnails Pane

» Select all thumbnails in the
navigation pane (Control + Click)

* Right-click one of the active
thumbnails, select Page Properties

 On the Tab Order tab, confirm Use
Document Structure is selected
and click OK.

fab Order | Actions

(1 Use Bow Order

1 Use Column Order

Choose one of the above options to
set the order for tabbing through

items on a page.
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Document Metadata

Document Title and Language



Document Properties

Description Security Fonts Initial View Custom Advanced

Description

- v
File: CRH Practical Matters for Patients.pdf
I Title:  Practical Matters for Patients I

Author:  John Smith

Subject:

Keywords:

First information read to screen e

Application: Microsoft® PowerPoint® for Microsoft 365
Advanced

PDF Producer:  Microsoft® PowerPoint® for Microsoft 365
PDF Version: 1.7 (Acrobat 8.x)

Loeation:  [Usersfamy.hepler/Downloads/

File Size:  4B1.93 KB (493,492 Bytes)

Page Size: 10.00 x 7.50 in Number of Pages: 12
G t F u I > P l u Tagged PDF:  Yes Fast Web View:  No
Help cancel | ([EIED

Under the Description tab, add
the title in the Title field

Layout and Magnification
Navigation tab:  Page Only a
Page layout: | Default (2]

Next, go to the Initial View tab L

Window Options

Resize window to initial page

Center window on screen

* Under Windows Options >
Show section, select Document
Title from the drop-down menu.

Help Cancel
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Document Language

Specify document language
for screen readers to read
correctly

* Go to File > Properties

 Under the Advanced tab, In
the Reading Options
section, select the
appropriate Language from
the drop-down

Document Properties

Description Security Fonts
PDF Settings
Base URL:

Search Index:

Trapped: Unknown a

Accessibility

POF/UA Cempliance: MNone

Print Dialog Presets
Page Scaling: Default
DuplexMode: Simplex

Paper Source by Page Size:
Print Page Range:

Mumber of Copies: Default B

Reading Options

Binding: LeftEdge B

Imit]

Language: English [~ ]

Protected Mode: On

ial View Custom Advanced |

X

Browse... Clear

NNNNNNNNNNNNN
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True or False?

Acrobat Pro is required to fix accessibility issues in PDFs.



Where is the Tags Pane in Acrobat?

A. In the Navigation Pane
B. In the Document Pane
C. In the Tasks Pane



Re-ordering content in the Order
Pane can significantly rearrange
the tag order in the Tags Pane

True or False?



The numbering shown in the Order
Pane is:

A. The screen reader reading order
B. The visual stacking order of different content layers
C. BothAand B



Tab order refers to:

The order in which ...

A. A screen reader will announce headings
B. A user tabs from one image to the next
C. Auser tabs through links and form fields



What happens if you don’t specify
the document language for a PDF?

The screen reader will ...

A. Read the document using the pronunciation of its default language
B. Automatically detect the language and read it correctly
C. Prompt the user to select which language they'd like the PDF to be read in



Assess Your PDF

Automated, Manual, Assistive Technology



Acrobat Pro DC Full Check

A

File Edit

* Go Tools > Accessibility >
Full Check

Leave all Checking Options
selected

Select Start Checking

* Note: Even if the full check
tool doesn’t find any issues,
you should still check

Home

View Window Help

Tools module-semantic-c... x

® 8 B Q

manually.

https://helpx.adobe.com/acrobat/using/create-verify-pdf-accessibility.html

Image credit: Deque

coessibility

Accessibility Checker

"W Document (3 issues)
o Accessibility permission flag - Passed
w# Image-only PDF - Passed
«F Tagged PDF - Passed
) Logical Reading Order - Needs manual check

¥ Primary langquage - Passed

Fix
Skip Rule

Explain

Check Again

o Tagged co

Show Report
o Tagged an
Options

¥ Tab order

5 R ™ O G

deque

Summary and Checklist: Semantic Stru

Tables [rortinued)
Hested or Split Tables

= Dhata table headers and dala ss5oistions MUST ROT
be referenced across nested, merged, or separate
tabdes,

Tabde Summmiany

s A& summary MAY be provided for dats tables,

» & data table summary, if provided, SHOULD make
he 1abile more understandable (o soreen reader
LEers

Layoud Tables

= Tables SHOULD HOT b used far the purpose of
purely visusl [nan-data) byaul

= Layout tables MUST NOT contain data table markoup.

Semantic Markup for Lists
= Lists MUST be corstructed using the sppropriate
semantic markup.

Frama titles
= [frames that corwey conbent Bo users MUST have a
ron-gmply tith attribute.
= The iframe 1ithe MUST Be aocursbe #ad dedcriplive,
= Frames MUST have 3 unigue titke [in the contest of
the page].
Page Title Within an Hrame
= The source page of an dframe MUST have a valid,
meaningful czitle
Semantic struciure across iframes
= Thi hesding Rlerarcty af & iirame SHOULD be
cesigned to fit within the heading hierarchy of the
parent document, If possible.
Hiding ifvames that dont contain meaninghil contant
& Hicdden frames or Frames that do not corwey comtent
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https://helpx.adobe.com/acrobat/using/create-verify-pdf-accessibility.html

Manual testing of a PDF is not
necessary if you use a quality
automatic tool.

True or False?
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